Обновление Magisk Canary добавляет поддержку устройств A-Only System-root

Экосистема Android поддерживает два типа разметки разделов: традиционная схема разметки (где виртуальный диск присутствует в разделе / ​​boot и смонтирован как rootfs, а система смонтирована в / system), и более новая схема разметки A / B , где система монтируется как rootfs. Google сделал систему root-root обязательной для устройств, запускаемых с Android 9 Pie (как часть изменений, внесенных для Project Treble ), но разделение A / B продолжает оставаться рекомендуемой, но необязательной функцией из-за необходимых изменений. Это означает, что есть новые устройства, которые будут запускаться с Android Pie, но поставляются с одним разделом «A-only». Для этих устройств OEM-производитель должен по-прежнему гарантировать, что телефон использует систему как root, что, в свою очередь, означает, что виртуальный диск должен быть объединен с образом системы, чтобы его можно было смонтировать как rootfs. Система с правами root не обязательна для устройств, которые обновляются до Android 9 Pie.

Этот сценарий создал проблему для пользователей, желающих запустить Magisk на своих устройствах. Magisk уже поддерживал системные устройства как root, но это было ограничено устройствами с более новой схемой разделения A / B. Некоторые китайские устройства, такие как Xiaomi Mi 8 SE и некоторые другие, а также, очевидно, новый Samsung Galaxy S10 , которые используют настройку системы как root без использования раздела A / B, в конечном итоге не смогут загрузиться, если Magisk был установлен на их Android Pie сборок.

Теперь Magisk добавил поддержку только для систем с правами root. Это изменение в настоящее время доступно в канале сборки Canary с номером сборки v18.2-e72c6685 (18111). Вы также можете установить сборки Canary через Magisk Manager, переключив канал обновления на пользовательский и вставив эту ссылку:

Обращаем ваше внимание на то, что канальный релиз-релиз считается «передовым краем» релизов Magisk, и поэтому рекомендуется только для разработчиков, а не для обычных пользователей. Пожалуйста, не устанавливайте сборки canary только ради того, чтобы быть в самой последней версии.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Каталог товаров

×